summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2021-09-29 14:26:44 +0800
committerlilac2021-09-29 14:26:44 +0800
commite630586aeb2503245f311d7162cbdb807b21f5dc (patch)
treecedbd886f34924fcc72cc2be9a6e0743326f7d02 /PKGBUILD
parentfb4d7016d6d8c1b04fe48cbb0e613df5e4dd5c47 (diff)
downloadaur-e630586aeb2503245f311d7162cbdb807b21f5dc.tar.gz
[lilac] updated to 0.7.4-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 3 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28374c1bb967..8bd0ac3a727c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=python-visions
_pkgname=visions
-pkgver=0.7.1
-pkgrel=3
+pkgver=0.7.4
+pkgrel=1
pkgdesc='Type System for Data Analysis in Python'
arch=('any')
url='https://github.com/dylan-profiler/visions'
@@ -25,30 +25,14 @@ makedepends=(
python-sphinx-autodoc-typehints
python-sphinx_rtd_theme
)
-checkdepends=(
- python-imagehash
- python-matplotlib
- python-pillow
- python-pydot
- python-pytest
- python-pytest-black
- python-pytest-mypy
- python-shapely
- twine
-)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/dylan-profiler/visions/archive/v${pkgver}.tar.gz")
-sha512sums=('788a31e5812fe2a729c1d2d1b3dc5b9816dad970b82084109ca2e1f0d7b0c5b77f29364358d608808a929840690a34f139ad9a0770a2be3e526048e3d3b6911d')
+sha512sums=('0ff3233fd59e1099c138f98fd46d94eb042f1d28c436db41fed5c12dad0a5d6f175db3122fafdbc7d76e0d487a152f530aca4d6aaef165c884f3e2b9d6ed1134')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build
}
-check() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- PYTHONPATH="${PWD}/build/lib" pytest -v
-}
-
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build