summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchmad Fathoni2022-03-26 19:26:46 +0700
committerAchmad Fathoni2022-03-26 19:26:46 +0700
commit4631b06e8d72c46b19cdc895934bbd15ca6ec47f (patch)
treec93593c22dc519ec0e1b7a51b2e7fc1d226b9f3a /PKGBUILD
downloadaur-4631b06e8d72c46b19cdc895934bbd15ca6ec47f.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eec312f6561d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+pkgname=python-voila
+_pkgname=${pkgname:7}
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="VoilĂ  turns Jupyter notebooks into standalone web applications"
+arch=('any')
+url="https://pypi.org/project/${pkgname}"
+license=(BSD)
+makedepends=(python-build python-installer python-wheel python-setuptools python-jupyter_packaging)
+depends=(
+ python
+ jupyter-server
+ python-jupyterlab_server
+ python-jupyter_client
+ jupyter-nbclient
+ jupyter-nbconvert
+ python-websockets
+ python-traitlets
+)
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('2e18062445a501fc24c4ae59bd53b2e81ba2d20a7d52516db5b13c3c934f22c4')
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1
+}