summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchmad Fathoni2023-06-29 11:13:24 +0800
committerAchmad Fathoni2023-06-29 11:13:24 +0800
commit9919a000b402f68d829c3b7626710d1e0997a3ea (patch)
treeee18da3fbc8b7c70ace46482d85b6c9691cb5da9 /PKGBUILD
parent4f83b5f873d14c46bc98e005976073a011fc779c (diff)
downloadaur-9919a000b402f68d829c3b7626710d1e0997a3ea.tar.gz
0.4.1 & Fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 29 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f069043ee43b..7eb1f97c0561 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
pkgname=python-voila
_pkgname=${pkgname:7}
-pkgver=0.4.0
-pkgrel=1
+pkgver=0.4.1
+pkgrel=2
pkgdesc="VoilĂ  turns Jupyter notebooks into standalone web applications"
arch=('any')
url="https://voila.readthedocs.io"
license=(BSD)
-makedepends=(python-build python-installer python-wheel python-setuptools python-jupyter_packaging)
+makedepends=(python-build python-installer python-wheel python-jupyter_packaging)
depends=(
python
jupyter-server
@@ -15,17 +15,40 @@ depends=(
python-jupyter_client
jupyter-nbclient
jupyter-nbconvert
+ jupyterlab
+ jupyter-notebook
+ jupyter-lsp
python-websockets
python-traitlets
+ python-hatchling
+ python-tinycss2
+)
+makedepends+=(
+ python-fqdn
+ python-webcolors
+ python-isoduration
+ python-jsonpointer
+ python-uri-template
+ python-rfc3339-validator
+ python-rfc3986-validator
+ python-jupyter-server-terminals
+ python-hatch-jupyter-builder
+ python-debugpy
)
source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
-sha256sums=('5c91fb969bffa3fc28846d8a3eeae804d71577ff49f2cab6b663ad325ae69ad0')
+sha256sums=('271e03cb8a9f7f92ab00edcaf6cc3a004c54ac64e1845a146fc6a67d374c3339')
+
+prepare() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ sed -i 's|jupyterlab~=3.0|jupyterlab>=3.0|g' pyproject.toml
+}
+
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd ${srcdir}/${_pkgname}-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}