summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-14 09:14:50 -0500
committerLuis Martinez2022-03-14 09:14:50 -0500
commitca225d144c78c017f4211159a4b25953247d9ad0 (patch)
tree20a45660f6b7fd56ca6d4be2e89025241496306c /PKGBUILD
parent5976bc943a4b6d252d2af66727010b8b1fae7166 (diff)
downloadaur-ca225d144c78c017f4211159a4b25953247d9ad0.tar.gz
update to 0.13.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 201c75c6fd65..3fdb8ad6c154 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,41 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=python-vt-py
-pkgver=0.13.1
+pkgver=0.13.2
pkgrel=1
pkgdesc="Official Python client library for VirusTotal's REST API"
arch=('any')
url="https://github.com/virustotal/vt-py"
license=('Apache')
depends=('python-aiohttp')
-makedepends=('python-pytest-runner' 'python-setuptools')
+makedepends=(
+ 'python-pytest-runner'
+ 'python-setuptools'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-sphinx')
checkdepends=('python-pytest-httpserver' 'python-pytest-asyncio')
provides=('python-virustotal')
replaces=('python-virustotal-api')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('cc106d33727c89c82577711f9e5cb625de72cde4f7a4370a3603b2d4d8dbe727')
+sha256sums=('c1378a1aaeffee7ef7ad57a460f90563fb57e1d25d7d54dd4398aef1c4dd6867')
build() {
cd "vt-py-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
+ cd docs
+ PYTHONPATH=../ sphinx-build -b man source _build
}
check() {
cd "vt-py-$pkgver"
- python setup.py pytest
+ pytest -x --disable-warnings
}
package() {
export PYTHONHASHSEED=0
cd "vt-py-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 docs/_build/vt-py.1 -t "$pkgdir/usr/share/man/man1/"
}