summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Rubin2023-09-04 22:15:54 +0200
committerMarco Rubin2023-09-04 22:15:54 +0200
commitc96163e7a6548c89e49c259faccc8e9efdac851e (patch)
tree2e487f33ab6114a9148c9833acdda6944409170a /PKGBUILD
parent7239bb4df0665a0e47d28d5ef75a82d468af6c94 (diff)
downloadaur-c96163e7a6548c89e49c259faccc8e9efdac851e.tar.gz
Cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6272921287a..908ec5b41f30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Aaron Coach <aur at ezpz dot cz>
+
+_name=pywakeonlan
pkgname=python-wakeonlan
-_pkg="${pkgname#python-}"
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Wake on LAN Python module'
-url="https://github.com/remcohaszing/pywakeonlan"
+url='https://github.com/remcohaszing/pywakeonlan'
arch=('any')
license=('MIT')
-depends=('python')
-makedepends=('python-build' 'python-installer' 'python-poetry-core')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/w/$_pkg/$_pkg-$pkgver.tar.gz")
-sha256sums=('9a2a7cede51e2d4777330592190ea6e8ba391513d74e6f91d3197669cac7c754')
+depends=('python>=3.7')
+makedepends=(python-build python-installer python-poetry-core python-wheel)
+source=("$url/archive/$pkgver.tar.gz")
+b2sums=('f41e5674b1db4ca9d263e0286e65f5697c45444d35b411f4dba37b71f11588137bb85e24625ccfba5f8154052e15f7b6a0d0c765746c59cb648404774a18ec74')
build() {
- cd "$_pkg-$pkgver"
+ cd $_name-$pkgver
python -m build --wheel --no-isolation
}
package() {
- cd "$_pkg-$pkgver"
+ cd $_name-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
- local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
- install -dv "$pkgdir/usr/share/licenses/$pkgname/"
- ln -sv "$_site/$_pkg-$pkgver.dist-info/LICENSE.rst" "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}