summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDario Ostuni2020-01-11 16:35:10 +0100
committerDario Ostuni2020-01-11 16:35:10 +0100
commit3c71d2accdf8e93fc1e8d5e7f0261b64b80c9021 (patch)
tree8b9d49fe67e667e30aff974e6dbed44c7752e358 /PKGBUILD
parentde63e3390163706bc19b76d08790472ff7170039 (diff)
downloadaur-3c71d2accdf8e93fc1e8d5e7f0261b64b80c9021.tar.gz
Update to version 0.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c3841b4f2f6..2977c181ee02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer: Dario Ostuni <another.code.996@gmail.com>
pkgname=python-wasmtime
-pkgver=0.3.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="Python 3 extension for interface with Wasmtime/Cranelift."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
-url="https://github.com/CraneStation/wasmtime"
+url="https://github.com/bytecodealliance/wasmtime"
license=('APACHE2')
depends=('python' 'python-setuptools' 'python-wheel' 'python-setuptools-rust')
makedepends=('rustup')
options=(!emptydirs)
-source=("https://github.com/CraneStation/wasmtime/archive/v${pkgver}.tar.gz")
-sha384sums=('c043bf58f24a174d832b14b4aa1a6de17cd608648753da65c64f33254e79df913ce0e709abcd9645e71ebed4c2134360')
+source=("${pkgname}-${pkgver}::git+https://github.com/bytecodealliance/wasmtime.git#tag=v${pkgver}")
+sha384sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ git submodule update --init --recursive
+}
+
package() {
- cd "$srcdir/wasmtime-${pkgver}/misc/wasmtime-py"
+ cd "${srcdir}/${pkgname}-${pkgver}/crates/misc/py"
rustup run nightly python setup.py install --root="$pkgdir/" --optimize=1
}