summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDario Ostuni2020-07-24 15:13:37 +0200
committerDario Ostuni2020-07-24 15:13:37 +0200
commit5cbfbfde339a82338bb0e8c0393d3cc9e6f1238b (patch)
tree6ffcb71bfdc0a8cbd5bcee08464b07bc8eeb1ad7 /PKGBUILD
parent669ef5c3bba5ad9335823436042d11296b955520 (diff)
downloadaur-5cbfbfde339a82338bb0e8c0393d3cc9e6f1238b.tar.gz
Update to version 0.19
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fc6b2899de5..882923652842 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Dario Ostuni <another.code.996@gmail.com>
pkgname=python-wasmtime
-pkgver=0.16.0
+pkgver=0.19.0
pkgrel=1
pkgdesc="Python 3 extension for interface with Wasmtime/Cranelift."
-arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+arch=('x86_64' 'aarch64')
url="https://github.com/bytecodealliance/wasmtime-py"
license=('APACHE2')
depends=('python' 'python-setuptools' 'python-wheel' 'wasmtime')
@@ -20,5 +20,7 @@ prepare() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="$pkgdir/" --optimize=1
- ln -sf "/usr/lib/libwasmtime.so" "${pkgdir}/""$(python -c "import setuptools as _; print(_.__path__[0][:-10])")""wasmtime/wasmtime.pyd"
+ PP="${pkgdir}/""$(python -c "import setuptools as _; print(_.__path__[0][:-10])")""wasmtime/""linux-$(uname -m)"
+ mkdir "${PP}"
+ ln -sf "/usr/lib/libwasmtime.so" "${PP}/_libwasmtime.so"
}