summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ. Nathanael Philipp2023-10-04 08:32:51 +0200
committerJ. Nathanael Philipp2023-10-04 08:32:51 +0200
commit17f774d76c83bce27b1d0f67a99096f3ba2b62d9 (patch)
tree92c647b64aee4cf883162403b9089895c85ddca2 /PKGBUILD
downloadaur-17f774d76c83bce27b1d0f67a99096f3ba2b62d9.tar.gz
Version 0.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f689379bb5ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: J. Nathanael Philipp (jnphilipp) <nathanael@philipp.land>
+
+pkgname=python-weasel
+_pkg="${pkgname#python-}"
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A small and easy workflow system"
+url="https://github.com/explosion/weasel/"
+depends=(
+ 'python-confection'
+ 'python-wasabi'
+ 'python-srsly'
+ 'python-typer'
+ 'python-cloudpathlib'
+ 'python-smart-open'
+ 'python-requests'
+ 'python-pydantic')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel')
+license=('MIT')
+arch=(any)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/explosion/$_pkg/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=("f6921ebc14b900ae087eb5981a30d1ef3f5c154a57faf6849023c4a148b76406")
+
+build() {
+ cd ${_pkg}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd ${_pkg}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}