summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2022-01-23 22:23:57 +1100
committerMatthew Gamble2022-01-23 22:23:57 +1100
commite5d0afcecf2db577ec958dc97a2534f250ba44af (patch)
treebee8c972161e66d025fba6152ff6c7889c1e8b7e /PKGBUILD
parent4083197339dba435f61317bc3a6644e0f7f0276b (diff)
downloadaur-e5d0afcecf2db577ec958dc97a2534f250ba44af.tar.gz
Bump pkgrel for python3.10 rebuild, other cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0195b190651e..8b1117f684f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-webpagecache
pkgver=1.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="A utility class for downloading webpages and storing them in an SQLite3 database as a cache."
arch=("any")
url="https://github.com/djmattyg007/python-webpagecache"
@@ -12,8 +12,17 @@ makedepends=("python-setuptools")
source=("https://github.com/djmattyg007/python-webpagecache/archive/${pkgver}.tar.gz")
sha256sums=("b1dd14eb05ff22d4ddf3a0790d14250537db78ae181812ab05491f637df5af7c")
+build() {
+ cd "python-webpagecache-${pkgver}"
+
+ python setup.py build
+}
+
package() {
cd "python-webpagecache-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-webpagecache/LICENSE.txt"
+ install -Dm644 REMADE.txt "${pkgdir}/usr/share/doc/python-webpagecache/README.txt"
}