summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexei Colin2019-03-27 01:32:36 -0400
committerAlexei Colin2019-03-27 01:32:36 -0400
commit1b40953a9b265918896ef4932efa3fabf75ae345 (patch)
tree7fff49a5361a971947e6d37fa74971b4b6d18572 /PKGBUILD
downloadaur-1b40953a9b265918896ef4932efa3fabf75ae345.tar.gz
west tool for Zephyr 0.5.6
Effectively part of zephyr-sdk.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a9f4f0379cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexei Colin <ac@alexeicolin.com>
+
+pkgname='python-west'
+_name="west"
+pkgdesc="Zephyr RTOS Project meta-tool (wrapper and bootstrap)"
+pkgver=0.5.6
+pkgrel=1
+arch=('any')
+url='https://pypi.org/project/west/'
+license=('Apache')
+depends=('python-configobj')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+
+build() {
+ cd $srcdir/$_name-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_name-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha256sums=('0cdae367f5b9439060dde5fd58ad794cbd70d7ab83f7cb8fe6b1bbc9a4301ece')