summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard Neumann2023-05-04 10:25:58 +0200
committerRichard Neumann2023-05-04 10:25:58 +0200
commitb35818e660564c79c6681384b8d4a88817fe3922 (patch)
tree69f7de00fa1e1b4fe0f298e5b30914e7d2c4c412 /PKGBUILD
parente42012f085300f9b7902186e6063099e3358b0c5 (diff)
downloadaur-b35818e660564c79c6681384b8d4a88817fe3922.tar.gz
Migrate to python-build and python-installer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bdc37f82a889..ab5a006796e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
_pkgbase='wgtools'
pkgname="python-${_pkgbase}"
pkgver=1.0.5
-pkgrel=1
+pkgrel=2
pkgdesc='Python bindings for wireguard-tools'
arch=('any')
url="https://github.com/conqp/${_pkgbase}"
license=('GPLv3')
depends=('python' 'python-setuptools' 'wireguard-tools')
-makedepends=('git' 'python-setuptools-scm')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
source=("${_pkgbase}::git+${url}.git#tag=${pkgver}")
sha256sums=('SKIP')
build() {
cd "${srcdir}/${_pkgbase}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgbase}"
- python setup.py install --root "${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}