summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2019-03-11 15:57:13 +0100
committerPhilipp A2019-03-11 15:57:13 +0100
commit15a82aef1ae1a4c4d26f4f1e1e10b5dfb30a5896 (patch)
treed4fc62dcd474110c77b5dbd2b58413ffb18a264d /PKGBUILD
downloadaur-15a82aef1ae1a4c4d26f4f1e1e10b5dfb30a5896.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5644d955cc13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=wheel-inspect
+pkgname=python-$_name
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='Extract information from wheels'
+arch=(any)
+url="https://github.com/jwodder/$_name"
+license=(MIT)
+depends=(python python-attrs python-headerparser python-packaging python-property-manager python-readme-renderer python-setuptools)
+_pyarch=py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('be942dbba09f7a0472942af0571cd57cc034fc19744543685a5210fbd34718ff')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+
+ cat >wheel2json.sh <<-EOF
+ #!/bin/sh
+ exec python3 -m wheel_inspect "\$@"
+ EOF
+ install -Dm755 wheel2json.sh "$pkgdir/usr/bin/wheel2json"
+}