summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoseph Diza2022-05-05 16:35:15 -0700
committerJoseph Diza2022-05-05 16:35:15 -0700
commit0b2c312dbcb880ec0e0ac865fa8289aa1003cdf8 (patch)
tree9dd3b6453eba2d91363d4c880a9946935a658679 /PKGBUILD
downloadaur-0b2c312dbcb880ec0e0ac865fa8289aa1003cdf8.tar.gz
Initial commit of python-wora-git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32884fcef711
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Joseph Diza <josephm.diza@gmail.com
+
+pkgname=python-wora-git
+pkgver=0.1.6
+pkgrel=1
+arch=('any')
+pkgdesc='Write once run anywhere, a python library with general purpose utilities.'
+url='https://github.com/jmdaemon/wora'
+license=('GPL')
+depends=('python-toml')
+optdepends=()
+makedepends=('python-setuptools')
+source=("$pkgname::git+https://github.com/jmdaemon/wora#branch=master")
+provides=(python-wora)
+conflicts=(python-wora)
+sha512sums=("SKIP")
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root "$pkgdir" --optimize=1
+}