summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriel Magno2023-12-31 12:11:13 -0300
committerGabriel Magno2023-12-31 12:11:13 -0300
commit8b683613acb06bcca6ebbaf34db7e6a3c8baf1b2 (patch)
tree155bbbc066dbf534a9f9e7f0a3aa79c6be6119b7 /PKGBUILD
parentadedb0d706cedacec7c3aba859c983a670fbb0b3 (diff)
downloadaur-8b683613acb06bcca6ebbaf34db7e6a3c8baf1b2.tar.gz
Modernized build based on PEP 517 and pyproject.toml
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e842e4e13d2f..71cf5925f025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,24 @@
_pkgname=wordcloud
pkgname=python-wordcloud
pkgver=1.9.3
-pkgrel=1
+pkgrel=2
pkgdesc="A little word cloud generator in Python"
arch=('any')
url="https://github.com/amueller/word_cloud"
license=('Apache')
-makedepends=('python-setuptools' 'cython')
+makedepends=('python-setuptools' 'python-setuptools-scm' 'python-build' 'python-installer' 'python-wheel' 'cython')
depends=('python' 'python-matplotlib' 'python-pillow' 'python-numpy')
source=("https://files.pythonhosted.org/packages/7c/60/5f927145b65de0f299079db846c89fa031d56e4df9764607add12a03714e/$_pkgname-$pkgver.tar.gz")
sha256sums=('a9aa738d63ed674a40f0cc31adb83f4ca5fc195f03a6aff6e010d1f5807d1c58')
+build() {
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 et: