summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorandalenavals2018-02-01 23:09:02 -0200
committerandalenavals2018-02-01 23:09:02 -0200
commitdc39744a5ce50909fcbcb463582d9d9d7ca2ccfd (patch)
tree9c72d5063e964fe7dc1980646a0e34720e1a0ff6 /PKGBUILD
downloadaur-python-wq-git.tar.gz
No test defined. But working
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..bf5cae8bd3b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: Erin Sheldon
+pkgbase=python-wq-git
+pkgname=('python-wq-git' 'python2-wq-git')
+pkgver=v0.1.0.r157.653a758
+pkgrel=1
+pkgdesc="This is a simple work queue written in python"
+arch=('any')
+url="https://github.com/esheldon/wq.git"
+license=('GPL')
+makedepends=('git' 'python' 'python2')
+source=("${pkgbase}::git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgbase}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cp -a $pkgbase{,-py2}
+}
+
+build() {
+ cd "$srcdir"/$pkgbase
+ python setup.py build
+
+ cd "$srcdir"/$pkgbase-py2
+ python2 setup.py build
+}
+
+package_python-wq-git() {
+ depends=('python')
+ cd $pkgbase
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
+
+package_python2-wq-git() {
+ depends=('python2' 'python')
+ cd $pkgbase-py2
+ python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+} \ No newline at end of file