summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKartik Mohta2020-05-31 11:22:40 -0700
committerKartik Mohta2020-05-31 11:22:40 -0700
commit4af7feeff450a23d0fcb480cd8e1207a0d011144 (patch)
tree6c623cb62776112209f555898126585411f1f754 /PKGBUILD
parent9e7256717087db3803d81817c7fbd05d93af8d56 (diff)
downloadaur-python-wstool.tar.gz
Switch source to github repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8437dd9e233..d9b9465a7df7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python-wstool'
pkgname=('python-wstool')
-_module='wstool'
-pkgver='0.1.17'
-pkgrel=2
-pkgdesc="workspace multi-SCM commands"
-url="http://wiki.ros.org/wstool"
+pkgver='0.1.18'
+pkgrel=1
+pkgdesc='Command-line tool for maintaining a workspace of projects from multiple version-control systems'
+arch=('any')
+url='https://github.com/vcstools/wstool'
+license=('BSD')
depends=('python' 'python-vcstools' 'python-yaml')
-conflicts=('python2-wstool')
makedepends=('python-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('c79b4f110ef17004c24972d742d2c5f606b0f6b424295e7ed029a48e857de237')
+
+conflicts=('python2-wstool')
+source=("https://github.com/vcstools/wstool/archive/${pkgver}.tar.gz")
+sha256sums=('f04621acda755a45896db2d3a84131f96cf69905515997637b4568f3fad5c46e')
+
+_module='wstool'
build() {
cd "${srcdir}/${_module}-${pkgver}"