summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Case2018-05-31 17:29:29 +0800
committerDaniel Case2018-05-31 17:29:29 +0800
commitb04def660d6140cedd27524fefe2777ad59d3ea7 (patch)
treeea2956a6b5f3d03d79a97a6cac6e205c351fc49e /PKGBUILD
downloadaur-python-x11_hash.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6d6c6b049ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Daniel Case <daniel@dashlabs.org>
+# Contributor: Andy Kluger <AndyKluger@gmail.com>
+
+_pkgname=x11_hash
+pkgname=python-${_pkgname}
+pkgver=1.4
+pkgrel=1
+pkgdesc="Binding for Dash's X11 proof of work hashing."
+arch=(any)
+url="https://github.com/mazaclub/x11_hash"
+license=('MIT')
+depends=('python3')
+makedepends=('python-setuptools')
+source=("https://github.com/mazaclub/x11_hash/archive/${pkgver}.tar.gz")
+
+package_python-x11_hash(){
+ cd ${_pkgname}-${pkgver}
+ python3 setup.py install --root="$pkgdir"
+}
+
+md5sums=('aeb83b7e868f504890a6a8d12c9ef2a0')