summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrás Wacha2022-06-02 15:36:43 +0200
committerAndrás Wacha2022-06-02 15:36:43 +0200
commita8c04c619ab0c6ad6e1167f7dba310a9d2d226cf (patch)
treeee4aaf6423455137d36c62825d15cc62b7a00e7e /PKGBUILD
parentbbb5df23fdeb152d7b6a8c9a7cd33a569191175c (diff)
downloadaur-a8c04c619ab0c6ad6e1167f7dba310a9d2d226cf.tar.gz
Added python-pip as a check-time dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9511ac5dbfa1..e11c03912808 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-xhtml2pdf
_name=${pkgname#python-}
pkgver=0.2.7
-pkgrel=1
+pkgrel=2
pkgdesc="A library for converting HTML into PDFs using ReportLab"
arch=(any)
url="https://github.com/xhtml2pdf/xhtml2pdf"
@@ -20,6 +20,7 @@ makedepends=(python-setuptools
# python-sphinx_rtd_theme
# texlive-latexextra
python-wheel)
+checkdepends=(python-pip)
source=("${_name}-${pkgver}.tar.gz::https://github.com/xhtml2pdf/xhtml2pdf/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('9157368e7cba3586cc119dfe339abaf5aa9b1e8150001c36c159816139e3718d')
build() {
@@ -40,4 +41,4 @@ package() {
# mkdir -p ${pkgdir}/usr/share/doc/${pkgname}
# cp ${srcdir}/${_name}-${pkgver}/docs/build/html ${pkgdir}/usr/share/doc/${pkgname} -R
# cp ${srcdir}/${_name}-${pkgver}/docs/build/latex/${_name}.pdf ${pkgdir}/usr/share/doc/${_name}.pdf
-} \ No newline at end of file
+}