summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-04-10 00:18:56 -0500
committerLuis Martinez2022-04-10 00:18:56 -0500
commitf5718143f9efefef28b7fdae27c3a538456e9a78 (patch)
tree346d6e0c309e73bfc47a26865d2be1b986592f40 /PKGBUILD
parentff37620137d59ac8f0b35098bd51e4ee3f4e7af5 (diff)
downloadaur-f5718143f9efefef28b7fdae27c3a538456e9a78.tar.gz
remove python2 package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 5 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0a216933fcc..b808821235bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-pkgname=('python-xmlformatter' 'python2-xmlformatter')
+pkgname=python-xmlformatter
pkgver=0.2.4
-pkgrel=2
+pkgrel=3
pkgdesc="Provides formatting of XML documents"
arch=('any')
url="https://github.com/pamoller/xmlformatter"
license=('MIT')
-makedepends=('python2-setuptools' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("$pkgname-$pkgver.tar.gz::https://pypi.python.org/packages/source/x/xmlformatter/xmlformatter-$pkgver.tar.gz")
sha256sums=('6d93c4bc04cffb1d4cf6eb9d9034018e9b264e4554269e7da67539ba4bff03f5')
build() {
cd "xmlformatter-$pkgver"
python -m build --wheel --no-isolation
- python2 -m setuptools.launch setup.py build
}
-# package for python 3
-package_python-xmlformatter() {
- depends=('python')
-
+package() {
cd "xmlformatter-$pkgver"
PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
@@ -31,16 +28,3 @@ package_python-xmlformatter() {
"$_site/xmlformatter-$pkgver.dist-info/LICENSE.txt" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# package for python 2
-package_python2-xmlformatter() {
- depends=('python2')
-
- cd "xmlformatter-$pkgver"
- PYTHONHASHSEED=0 python2 -m setuptools.launch setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
-
- # non-conflicting executable name
- mv "$pkgdir"/usr/bin/xmlformat "$pkgdir"/usr/bin/xmlformat2
-}