summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvan Konovalov2019-07-06 20:57:48 +0500
committerIvan Konovalov2019-07-06 20:57:48 +0500
commit317cb92c7c84d8f3c7148a8be6d154c941301a7c (patch)
treea0a4fe167fb569e0a9fec90aedd5d568a84cf329 /PKGBUILD
downloadaur-317cb92c7c84d8f3c7148a8be6d154c941301a7c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2a7a432bc1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Ivan Konovalov <ivknv0@gmail.com>
+
+pkgname=python-yadisk-async
+_name=${pkgname#python-}
+_py=py3
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Yandex.Disk REST API client library for Python with async/await support"
+arch=('any')
+url="https://github.com/ivknv/yadisk-async"
+license=('LGPL3')
+depends=('python>=3.6.0' 'python-aiohttp')
+makedepends=('python-pip')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-$pkgver.tar.gz")
+sha256sums=("e2f0386556ffe3872dddc629dbe963b4d06a699f03eeee5adc5904f2bd5a7836")
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.tar.gz
+}