summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Kudelin2020-05-18 20:16:35 +0300
committerAnton Kudelin2020-05-18 20:16:35 +0300
commit3990bbba1f48f0a5e60ad7b352d69657b9d95cf5 (patch)
treef33cba0cb1595d19f9a4e7248b06e0c7f49ac158 /PKGBUILD
parent0e17060eeee1883922e9e9cb8760bb36ae413a06 (diff)
downloadaur-3990bbba1f48f0a5e60ad7b352d69657b9d95cf5.tar.gz
Applied a patch from commit 72 on github
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe98170348a3..7666e85d1642 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,23 @@
# Contributor: HÃ¥vard Pettersson <mail@haavard.me>
_name=yahoofinancials
-pkgname=(python-$_name)
+pkgname=python-$_name
pkgver=1.5
-pkgrel=1
+pkgrel=2
pkgdesc='A powerful financial data module used for pulling data from Yahoo Finance'
url='https://github.com/JECSand/yahoofinancials'
arch=('any')
license=('MIT')
depends=('python-requests' 'python-beautifulsoup4' 'python-pytz')
makedepends=('python-setuptools')
-source=("https://github.com/JECSand/$_name/archive/$pkgver.tar.gz")
-sha256sums=('372d30edbb25e6bd6fafa73bf915412b40522912cff14cba9ec28a50a3a105bd')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ "72.patch")
+sha256sums=('372d30edbb25e6bd6fafa73bf915412b40522912cff14cba9ec28a50a3a105bd'
+ '837ff84e3e285bb5e8da0323c7d520f6ff5df3ce9b28cad1da390a8f896c99ad')
build(){
cd "$srcdir/$_name-$pkgver"
+ patch -p1 < ../72.patch
python setup.py build
}