summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Warrick2014-12-31 11:08:06 +0100
committerChris Warrick2014-12-31 11:08:06 +0100
commitaa830d2604e7af0bc9e1870203ce9e36f380dc53 (patch)
treed3e63ca669fec68d17516deb46ec681f457b1d5a /PKGBUILD
downloadaur-aa830d2604e7af0bc9e1870203ce9e36f380dc53.tar.gz
init python-yapsy-hg
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..affefa7574d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Chris Warrick <aur@chriswarrick.com>
+pkgname=python-yapsy-hg
+pkgver=306.b04552174a5f
+pkgrel=1
+pkgdesc='Yet another plugin system (hg version)'
+arch=('any')
+url='http://yapsy.sourceforge.net/'
+license=('BSD')
+depends=('python')
+makedepends=('mercurial')
+options=(!emptydirs)
+provides=('python-yapsy')
+conflicts=('python-yapsy')
+source=("hg+http://hg.code.sf.net/p/yapsy/code")
+md5sums=('SKIP')
+
+package() {
+ cd "${srcdir}/code/package"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+pkgver() {
+ cd "${srcdir}/code"
+ hg identify -ni | awk 'BEGIN{OFS=".";} {print $2,$1}'
+}
+
+# vim:set ts=2 sw=2 et: