summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoseph Brains2017-06-21 17:24:05 +0300
committerJoseph Brains2017-06-21 17:24:05 +0300
commit562c5314d3a363aa523f92d5f4327b53dba2798c (patch)
tree575256154d26576456a95d7b044ab54a34657b5c /PKGBUILD
downloadaur-562c5314d3a363aa523f92d5f4327b53dba2798c.tar.gz
Initial commit for python-yarl GNS3 2x locked
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11d8b973d8ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Joseph Brains <jnbrains@gmail.com>
+_pkgname=yarl
+pkgname=python-${_pkgname}-gns3
+pkgver=0.9.8
+pkgrel=1
+pkgdesc="Yet another URL library (GNS3)"
+arch=('any')
+url="https://github.com/aio-libs/yarl/"
+license=('Apache')
+groups=('gns3')
+provides=("python-${_pkgname}")
+conflicts=("python-${_pkgname}")
+depends=('python' 'python-multidict')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/aio-libs/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('1402ac5548c5fabf6072952ee513d084')
+
+package() {
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+}