summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandrParkhomenko2020-03-23 20:45:04 +0300
committerAlexandrParkhomenko2020-03-23 20:45:04 +0300
commit3b8ded026f77673b3f8252a6353d6fad1e6229d2 (patch)
tree2f66a50b07e3c5b1e08b53d572b2d4056fcc14a3 /PKGBUILD
downloadaur-3b8ded026f77673b3f8252a6353d6fad1e6229d2.tar.gz
welcome
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66753d6917ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alexandr Parkhomenko
+
+_module=yfinance
+pkgname=python-yfinance-git
+pkgver=1
+pkgrel=1
+pkgdesc="Yahoo! Finance market data downloader (+faster Pandas Datareader) "
+url="https://github.com/ranaroussi/yfinance"
+depends=('python-requests' 'python-multitasking-git')
+makedepends=('python-setuptools')
+license=('apache2')
+arch=('any')
+source=("git://github.com/ranaroussi/yfinance")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${_module}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+