summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Cholasta2016-08-02 13:39:27 +0200
committerJan Cholasta2016-08-02 13:39:52 +0200
commitbdd4dda9253fa0cc3b8fee7ab3a9da59c7a029aa (patch)
tree6fc5b992cbbd84dcba86ffac8e164d74bd086b3a /PKGBUILD
parent0b5b70be79f197b6d3d24b9b9ddaa91f9a941d3a (diff)
downloadaur-bdd4dda9253fa0cc3b8fee7ab3a9da59c7a029aa.tar.gz
Update to 1.3.2
Correct license to BSD. Package docs.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee46e713ab9f..5c2110947d42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,36 @@
# Based on Fedora python-yubico.spec
pkgname=python2-yubico
-pkgver=1.3.1
+pkgver=1.3.2
pkgrel=1
pkgdesc="Pure-python library for interacting with Yubikeys"
arch=('any')
url="https://github.com/Yubico/python-yubico"
-license=('GPL')
+license=('BSD')
depends=('python2-pyusb>=1.0.0')
makedepends=('python2-setuptools')
checkdepends=('python2-nose')
source=("https://github.com/Yubico/python-yubico/archive/python-yubico-$pkgver.tar.gz")
-sha256sums=('80a51a2eccde17724b7da3b04558e81ec49f94cc29dc1c13ab51a594d50a6b4a')
+sha256sums=('3fd3779cdc39a0347e7a0af0923ebfcf5b4feacca6034a1072a03cb18113ed3a')
build() {
- cd python-yubico-python-yubico-$pkgver
+ cd "python-yubico-python-yubico-$pkgver"
python2 setup.py build
}
check() {
- cd python-yubico-python-yubico-$pkgver
+ cd "python-yubico-python-yubico-$pkgver"
# Exclude tests that require a physical yubikey attached.
nosetests2 -e test_challenge_response -e test_serial -e test_status
}
package() {
- cd python-yubico-python-yubico-$pkgver
+ cd "python-yubico-python-yubico-$pkgver"
python2 setup.py install -O1 --skip-build --root "$pkgdir"
+
+ install -D -m644 -t "$pkgdir"/usr/share/licenses/"$pkgname" COPYING
+ install -D -m644 -t "$pkgdir"/usr/share/doc/"$pkgname" NEWS README
}