summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Wojdyła2022-10-10 21:36:56 +0200
committerMichał Wojdyła2022-10-10 21:36:56 +0200
commit4f1525edcf48c260567a56cd414909f842dd4ba1 (patch)
tree93c1a48ab8a5c44650d21ab573213bdcba2eca64 /PKGBUILD
parent288f1c480a099b52ab29bb6920f5fe7f9b288d07 (diff)
downloadaur-4f1525edcf48c260567a56cd414909f842dd4ba1.tar.gz
add workaround for test_curses
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79d76de252eb..85d6278607b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=python2
pkgver=2.7.18
-pkgrel=6
+pkgrel=7
_pybasever=2.7
pkgdesc="A high-level scripting language"
arch=('x86_64')
@@ -14,7 +14,7 @@ license=('PSF')
url="https://www.python.org/"
depends=('bzip2' 'expat' 'gdbm' 'libffi' 'libnsl' 'libxcrypt' 'openssl' 'sqlite' 'zlib')
makedepends=('tk' 'bluez-libs')
-checkdepends=('gdb' 'file' 'xorg-server-xvfb')
+checkdepends=('gdb' 'file' 'xorg-server-xvfb' 'xterm')
optdepends=('tk: for IDLE'
'python2-setuptools'
'python2-pip')
@@ -102,7 +102,7 @@ check() {
# Since 2.7.15: test_ctypes
# test_ftplib test_imaplib test_urllib2_localnet: krb5 errors
# test_codecmaps_jp: TODO
-
+ export TERM=xterm
cd Python-${pkgver}
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
xvfb-run "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_idle test_tk test_ttk_guionly test_ctypes test_ssl test_ftplib test_imaplib test_urllib2_localnet test_codecmaps_jp