summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfordprefect2019-03-24 16:56:28 +0100
committerfordprefect2019-03-24 16:56:28 +0100
commitd9ae72c2cb85f90d25b2aa96cadbf77edf4f0f8f (patch)
tree5dfd23ee8a5d7aad60a1d47504e7c2876a3a2717 /PKGBUILD
parent61310669cf9a873fbdd25611ccb239bc11270fe9 (diff)
downloadaur-d9ae72c2cb85f90d25b2aa96cadbf77edf4f0f8f.tar.gz
update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 3 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e454ac1f2cb..3c03a712d74e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=("python2-androguard" python-androguard)
pkgbase=python2-androguard
pkgver=3.3.5
-pkgrel=1
+pkgrel=2
pkgdesc="Python framework for Android application analysis."
arch=("any")
url="https://github.com/androguard/androguard/"
@@ -14,39 +14,13 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/androguard/androguard/archi
md5sums=('903bd3b46cdd677757227edbd652a455')
package_python2-androguard() {
- depends=("python2" "python2-setuptools")
- optdepends=(
- "ipython2: interactive analysis support"
- "python2-pygments: color support"
- #"pydot: CFG support"
- "python2-magic: file identification support"
- "sparsehash: elsim support"
- "muparser: elsim support"
- "snappy: elsim support"
- "bzip2: elsim support"
- "zlib: elsim support"
- #"psyco2-svn: acceleration support"
- "python2-pyside: GUI"
- )
+ depends=("python2" "python2-setuptools" "ipython2<6" "python2-future" "python2-networkx" "python2-pygments" "python2-colorama" "python2-matplotlib" "python2-asn1crypto" "python2-click" "python2-pydot")
cd "$srcdir/androguard-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1
}
package_python-androguard() {
- depends=("python" "python-setuptools")
- optdepends=(
- "ipython: interactive analysis support"
- "python-pygments: color support"
- #"pydot: CFG support"
- "python-magic: file identification support"
- "sparsehash: elsim support"
- "muparser: elsim support"
- "snappy: elsim support"
- "bzip2: elsim support"
- "zlib: elsim support"
- #"psyco-svn: acceleration support"
- "python-pyside: GUI"
- )
+ depends=("python" "python-setuptools" "ipython" "python-future" "python-networkx" "python-pygments" "python-lxml" "python-colorama" "python-matplotlib" "python-asn1crypto" "python-click" "python-pydot")
cd "$srcdir/androguard-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1