summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonne Haß2019-09-24 19:55:35 +0200
committerJonne Haß2019-09-24 19:55:35 +0200
commita50080289a888dc0559db60ad1b40119657459b5 (patch)
tree94a01bfb34f8b2a0c9849cc03bb7142c1f5665b3 /PKGBUILD
downloadaur-python2-argon2.tar.gz
python2-argon2: add
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4927911c923d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase='python2-argon2'
+pkgname=('python2-argon2')
+_module='argon2'
+pkgver='0.1.10'
+pkgrel=1
+pkgdesc="Bindings for the argon2 password hasher"
+url="https://github.com/flamewow/argon2_py"
+depends=('python2')
+makedepends=('python2-setuptools')
+license=('unknown')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('523a3d3b88f3a46244b4976a6ca81994705848538bbe9e41426ea54ccb75eb90')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}