summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorclu2015-06-20 19:39:16 -0600
committerclu2015-06-20 19:39:16 -0600
commit600f0f9a8e8681c194b63f473bbf12c0541efbfc (patch)
treef8d3136ef0744f3d03082c879f843114f443f971 /PKGBUILD
downloadaur-600f0f9a8e8681c194b63f473bbf12c0541efbfc.tar.gz
Initial import to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59e3778849ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: clu
+
+pkgname=python2-astlib
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Python astronomy modules"
+arch=('i686' 'x86_64')
+url="http://astlib.sourceforge.net"
+license=("LGPL2.1")
+depends=('python2' 'python2-astropy>=0.4' 'python2-numpy>=1.3.0' 'python2-scipy>=0.7.1' 'python2-matplotlib>=0.98.3')
+makedepends=('python2' 'python2-distribute')
+source=("http://downloads.sourceforge.net/project/astlib/astlib/$pkgver/astLib-$pkgver.tar.gz")
+sha1sums=('cbd999f87773002e471bd165927c2ee124a5515f')
+
+package() {
+ cd $srcdir/astLib-$pkgver
+ python2 setup.py install --root=$pkgdir --prefix=/usr --optimize=1
+}