summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuan Guo2015-06-17 21:30:28 +0200
committerQuan Guo2015-06-17 21:30:28 +0200
commit3aac2a62267aca2b250ab99759a9b57fee7f2701 (patch)
tree57a29b1ed73afb2a2174a125fd06a83482cf2d31 /PKGBUILD
downloadaur-python2-astroml.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2b170be2a31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Quan Guo <guotsuan@gmail.com>
+
+pkgname=python2-astroml
+_pkgname=astroML
+pkgver=0.3
+pkgrel=1
+pkgdesc="AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib."
+
+url='http://www.astroml.org/'
+arch=('any')
+license=('BSD-3-Clause')
+depends=('python2-numpy' 'python2-scipy' 'python2-scikit-learn'
+ 'python2-matplotlib')
+
+optdepends=('astroml-examples')
+conflicts=('python2-astroml-git')
+
+source=("https://pypi.python.org/packages/source/a/astroML/astroML-${pkgver}.tar.gz")
+md5sums=('56d5c281ca079eb569ef1898be1604db')
+
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 ./setup.py install --root="${pkgdir}" --prefix=/usr
+}