summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCedric Girard2016-08-08 16:48:31 +0200
committerCedric Girard2016-08-08 16:48:31 +0200
commitbe2838a272752fc2aa4122a48ae206df8d0a8c9e (patch)
tree7eb50e83364d26a80707b033745a7ad966f085b6 /PKGBUILD
parent7e94cde639073890041c8a17e80c5134e98e27da (diff)
downloadaur-be2838a272752fc2aa4122a48ae206df8d0a8c9e.tar.gz
new upstream version with updated deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06beaf676f25..d358e8027f9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,23 @@
# Maintainer: Cedric Girard <girard.cedric@gmail.com>
_pythonmod=boto3
pkgname=python2-boto3
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=1
pkgdesc="The AWS SDK for Python"
arch=('any')
url="http://pypi.python.org/pypi/${_pythonmod}"
license=('Apache')
-depends=('python2' 'python2-botocore>=1.4.1' 'python2-botocore<1.5.0' 'python2-jmespath<1.0.0' 'python2-futures<4.0.0')
+depends=(
+ 'python2'
+ 'python2-botocore>=1.4.1'
+ 'python2-botocore<1.5.0'
+ 'python2-jmespath<1.0.0'
+ 'python2-s3transfer>=0.1.0'
+ 'python2-s3transfer<0.2.0'
+ )
makedepends=('python2-setuptools')
source=("https://pypi.io/packages/source/${_pythonmod:0:1}/${_pythonmod}/${_pythonmod}-$pkgver.tar.gz")
-md5sums=('e6be09a90230390640873979702dd6da')
+md5sums=('4b5454e8d29dede99092616023828a21')
build() {
cd ${srcdir}/${_pythonmod}-$pkgver