summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbao7uo2018-01-25 12:05:14 +0000
committerbao7uo2018-01-25 12:05:14 +0000
commitc04e49dd8c2c8c3ab423ba18a3a51ed35711bb6f (patch)
tree8fa17a7ed2ef1d03530ed071d16bbd9bb82380f4 /PKGBUILD
downloadaur-c04e49dd8c2c8c3ab423ba18a3a51ed35711bb6f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f3ba46c95d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Paul Taylor <bao7uo at gmail dot com>
+# Contributer: BlackArch
+
+pkgname='python2-bs4'
+pkgver='0.0.1'
+pkgrel=1
+pkgdesc='Beautiful Soup. bs4 name required by CrackMapExec'
+arch=('any')
+url='https://pypi.python.org/pypi/bs4/'
+license=('custom:unknown')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://pypi.python.org/packages/10/ed/7e8b97591f6f456174139ec089c769f89a94a1a4025fe967691de971f314/bs4-${pkgver}.tar.gz")
+sha1sums=('b309d9b50489cc64263d11491e6a19c29c3a484d')
+
+build() {
+ cd "$srcdir/bs4-$pkgver"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/bs4-$pkgver"
+
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+