summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohamar Rios Flores2018-05-24 04:03:03 -0600
committerMohamar Rios Flores2018-05-24 04:03:03 -0600
commit73cea9db9aa586fd51a5ec4b25c654b32da98108 (patch)
treeea50de4232f45406bbb153670f22b6b4865a7191 /PKGBUILD
parentcba0c7a2af85c717dc045ab513ba0a33088b0bc3 (diff)
downloadaur-python2-cashew.tar.gz
fixing links
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64d7e3adf9f4..c4aa78d0ec06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mohamar Rios <mohamar.rios@gmail.com>
-_pkgname=cashew
-pkgname=python2-${_pkgname}
+pkgname=python2-cashew
+_name=${pkgname#python2-}
pkgver=0.2.7
pkgrel=1
pkgdesc="The plugin system used by dexy."
@@ -13,14 +13,14 @@ depends=('python2'
'python2-inflection>=0.2.0')
makedepends=('python2-setuptools')
options=(!emptydirs)
-provides=("${_pkgname}")
-source=("https://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+provides=("${_name}")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
"LICENSE::https://raw.githubusercontent.com/dexy/cashew/master/LICENSE")
-md5sums=('e7a3801bf2ac92817d33292ea25efe5e'
- '7ae0144577340e245b148893690d7f37')
+sha256sums=('b75095f0b13547cb39db8897f535c26a2859bd8152bd704d545ba72546ea9fda'
+ '87159e27fa3f901ea96b5ca028c1695c531bdbadfd4cd8aee37661ca9d28bfb8')
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python2 setup.py install --root="${pkgdir}/" --optimize=1
install -Dm644 ${srcdir}/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE