summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0x9fff002019-12-19 19:58:07 +0100
committer0x9fff002019-12-19 19:58:07 +0100
commit0f64dec32bfdb4eddebe21da345aeb1ba1a67dc4 (patch)
treed4f2d648f32f5422edabe62037ebf91801ceef87 /PKGBUILD
parent7fedb03e577de870f003e13e3adde5b04084ce26 (diff)
downloadaur-0f64dec32bfdb4eddebe21da345aeb1ba1a67dc4.tar.gz
Import from [community]
Based on https://git.archlinux.org/svntogit/community.git/tree/repos/community-any/PKGBUILD?h=packages/python-clint&id=8765bd815000633efeb21ccfa65859bf5dcabe0f
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0981ae2a331..59c4f8017e01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
-# Maintainer: XavierCLL
-# Contributor: Alexander <rodseth@gmail.com>
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+# Contributor: Alexander F Rødseth <rodseth@gmail.com>
-pkgname=python2-clint
+# Based on python-clint in [community]
+
+_name=clint
+pkgname=python2-$_name
pkgver=0.5.1
-pkgrel=1
-pkgdesc="Module for developing commandline applications"
+pkgrel=9
+pkgdesc='Module for developing command line applications'
arch=('any')
-url="http://pypi.python.org/pypi/clint/"
-license=('ISC')
+url="https://pypi.org/project/$_name/"
+license=('custom:ISC')
depends=('python2')
-conflicts=('python2-clint-git')
-source=("http://pypi.python.org/packages/source/c/clint/clint-$pkgver.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('05224c32b1075563d0b16d0015faaf9da43aa214e4a2140e51f08789e7a4c5aa')
-package() {
- cd "$srcdir/clint-$pkgver"
+build() {
+ cd $_name-$pkgver
- python2 setup.py install --install-data="/usr/share/doc/$pkgname" \
- --root="$pkgdir"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python2 setup.py build
}
+package() {
+ cd "$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build \
+ --install-data="/usr/share/doc/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}