summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2020-03-16 11:16:52 +0100
committerBalló György2020-03-16 11:16:52 +0100
commitb035b9e3aeee701b17f0acd56230c24453be18d2 (patch)
treed1c06e4ca2e606d1aecdd9746c43a933041ccb2b /PKGBUILD
downloadaur-b035b9e3aeee701b17f0acd56230c24453be18d2.tar.gz
Move from [community]
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6a66a28f99b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
+
+pkgname=python2-cmd2
+pkgver=0.8.9
+pkgrel=1
+pkgdesc="A tool for building interactive command line applications in Python"
+arch=('any')
+url="https://github.com/python-cmd2/cmd2"
+license=('MIT')
+depends=('python2-pyparsing' 'python2-pyperclip' 'python2-six' 'python2-wcwidth'
+ 'python2-contextlib2' 'python2-enum34' 'python2-subprocess32')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest-runner' 'python2-pytest-xdist' 'python2-mock' 'vi')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/python-cmd2/cmd2/archive/$pkgver.tar.gz")
+sha512sums=('1d88e98ced08760f745a426dbf7031e2f8132484e0be833fb7afbbe0b02a0d5416ef7c852dd816cba0329d10356714cfc73fb303bdc885e982223b717d4508cc')
+
+build() {
+ cd cmd2-$pkgver
+ python2 setup.py build
+}
+
+check() {
+ cd cmd2-$pkgver
+ python2 setup.py pytest
+}
+
+package() {
+ cd cmd2-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: