summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 21:34:24 +0200
committerAndrzej Giniewicz2015-07-07 21:34:24 +0200
commit5af4406db3f0d874481c5378ca73f004a0e43a63 (patch)
treeb5eb983ec58c076ae96673fb1756889475735f92 /PKGBUILD
downloadaur-python2-codetools.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..502acf86c085
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+pkgname=python2-codetools
+pkgver=4.2.0
+pkgrel=1
+pkgdesc="Code Analysis and Execution Tools"
+arch=('any')
+url="https://github.com/enthought/codetools"
+license=('BSD')
+depends=('python2-traits')
+makedepends=('python2-distribute')
+conflicts=('python2-codetools-git' 'python-ets-codetools-svn')
+options=(!emptydirs)
+
+source=("https://github.com/enthought/codetools/archive/${pkgver}.tar.gz")
+md5sums=('bb1554c7deeb2d1821ad097344efd3eb')
+
+build() {
+ cd "$srcdir"/codetools-$pkgver
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"/codetools-$pkgver
+
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+
+ sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find "${pkgdir}" -name '*.py')
+
+ install -D "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+