summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuan Guo2015-06-17 21:30:48 +0200
committerQuan Guo2015-06-17 21:30:48 +0200
commit682052857a100f061913ac9ce8750075c739c0cb (patch)
tree3ad8a507d56d829849f9441e7d465ee37055b2e9 /PKGBUILD
downloadaur-python2-cosmolopy.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38a580a5fb4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#Maintainer: Quan Guo <guotsuan@gmail.com>
+
+pkgname=python2-cosmolopy
+pkgver=0.1.103.r20.gf23ea37
+pkgrel=1
+pkgdesc="a cosmology package for Python"
+url="http://roban.github.com/CosmoloPy/"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('python2-scipy' 'python2-numpy')
+makedepends=('cython2' 'git')
+source=(cosmolopy::git+https://github.com/roban/CosmoloPy.git)
+md5sums=('SKIP')
+provides=('python2-cosmolopy')
+
+_gitname="cosmolopy"
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+
+package() {
+ cd "$srcdir"/${_gitname}
+ python2 setup.py install --prefix=/usr --root="$pkgdir"/ --optimize=1
+}
+