summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn-Gee2021-02-04 00:59:12 -0800
committerJohn-Gee2021-02-04 00:59:12 -0800
commitbfc4d3efd019d51b30c94a1bffc2e9706847a8bc (patch)
treef25056d3b35b7b4129daf301215e07a1c85963bf /PKGBUILD
parent7dccd4c60ce4febd1ceccf2514dbb06fd6020030 (diff)
downloadaur-bfc4d3efd019d51b30c94a1bffc2e9706847a8bc.tar.gz
Updated the pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d47ccef9a242..700b2a666092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
_pkgname=crcmod
pkgname=python2-crcmod
pkgver=1.7
-pkgrel=1
+pkgrel=2
pkgdesc="Cyclic Redundancy Check (CRC) implementation in Python."
arch=('i686' 'x86_64')
url="https://pypi.python.org/pypi/crcmod/"
license=('MIT')
groups=()
depends=('python2')
-makedepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
+makedepends=('python2-setuptools')
options=(!emptydirs)
-install=
source=("https://pypi.python.org/packages/source/c/$_pkgname/$_pkgname-${pkgver}.tar.gz")
md5sums=(2d5b92117d958dcead94f9e17f54cd32)
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
package() {
cd "$srcdir/$_pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 et: