summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOleg Plakhotniuk2015-06-23 15:27:32 -0500
committerOleg Plakhotniuk2015-06-23 15:27:32 -0500
commit41fb646a4a4230d1325478d26bb2dab08d46a4a9 (patch)
tree20c82fd593d54cd7c97aa77084dd6170777222f9 /PKGBUILD
downloadaur-python2-diethack.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42deac12a1f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Oleg Plakhotniuk <olegus8@gmail.com>
+pkgname=python2-diethack
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Diet problem solver with Dietary Reference Intakes in mind."
+arch=('any')
+url="http://www.diethack.org"
+license=('custom')
+depends=('glpk' 'python2')
+makedepends=('git' 'python2-setuptools' 'unzip')
+source=("git+https://github.com/diethack/diethack#tag=${pkgver}"
+ 'https://www.ars.usda.gov/SP2UserFiles/Place/80400525/Data/SR27/dnload/sr27asc.zip')
+md5sums=('SKIP'
+ '74ed79e23e2eefc019bcebd34e9d4228')
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/{,doc/,licenses/}"$pkgname"
+ cp -r "$srcdir/diethack/src/examples" "$pkgdir/usr/share/$pkgname"
+ cp "$srcdir/diethack/README.md" "$pkgdir/usr/share/doc/$pkgname"
+ cp "$srcdir/diethack/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+
+ cd "$srcdir/diethack/src"
+ unzip "$srcdir/sr27asc.zip" -d diethack/nndb
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}