summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErhan SAHIN2015-06-10 01:13:48 +0300
committerErhan SAHIN2015-06-10 01:13:48 +0300
commitc6560e63b02b8e5da41293a00d0b1bb74fea6ead (patch)
tree7f6f8b03574ddc5778a74842f492e93392d618ea /PKGBUILD
downloadaur-python2-django-kilo.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b52ac97b205
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgname=python2-django-kilo
+pkgver=1.7.8
+pkgrel=1
+pkgdesc="A high-level Python Web framework that encourages rapid development and clean design"
+arch=('any')
+license=('BSD')
+url="http://www.djangoproject.com/"
+makedepends=('python2' 'python2-setuptools')
+replaces=('django')
+conflicts=('django')
+provides=('python2-django')
+optdepends=('mysql-python: for MySQL backend'
+ 'python2-psycopg2: for PostgreSQL backend')
+source=("https://www.djangoproject.com/m/releases/${pkgver:0:3}/Django-$pkgver.tar.gz")
+md5sums=('ceed714b0d69983da2b585ff4f82c4a8')
+
+build() {
+ cd "$srcdir/Django-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/Django-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ ln -s django-admin.py "$pkgdir"/usr/bin/django-admin2.py
+ install -Dm644 extras/django_bash_completion \
+ "$pkgdir"/usr/share/bash-completion/completions/django-admin.py
+ ln -s django-admin.py \
+ "$pkgdir"/usr/share/bash-completion/completions/manage.py
+
+ find "$pkgdir"/usr/lib/python2.7/site-packages/django/ -name '*.py' | \
+ xargs sed -i "s|#!/usr/bin/env python$|#!/usr/bin/env python2|"
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}