summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2016-09-04 21:27:46 +0200
committerMuflone2016-09-04 21:27:46 +0200
commit7e465ab087272a124ce6973f5bd7ad03245f51ef (patch)
tree69ba17d4ab7dc3e3f0269b2e75b9e7f88f4775dd /PKGBUILD
parent59f66e27693649f9bc5a0939ca21452ada6c020b (diff)
downloadaur-python2-docs-devhelp.tar.gz
Updated package python2-docs-devhelp 2.7.12-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 827609d964e2..6929e668f7ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,13 @@
pkgname=python2-docs-devhelp
pkgver=2.7.12
-pkgrel=1
-pkgdesc="Set of HTML documentation for Python 2.x with GNOME-Devhelp support."
+pkgrel=2
+pkgdesc="Set of HTML documentation for Python 2.x with GNOME Devhelp support."
arch=('any')
makedepends=('python2' 'python2-sphinx')
+depends=('devhelp')
provides=('python2-docs')
+conflicts=('python2-docs')
url="http://docs.python.org/"
license=('GPL')
options=('docs')
@@ -38,13 +40,15 @@ build() {
}
package() {
+ # Copy files
install -m 755 -d "${pkgdir}/usr/share/doc/python2/html"
- install -m 755 -d "${pkgdir}/usr/share/devhelp/books"
cp -rf "${srcdir}/Python-${pkgver}/Doc/build/devhelp"/* \
"${pkgdir}/usr/share/doc/python2/html/"
find "${pkgdir}/usr/share/doc/python2/html/" -type f -exec chmod 0644 {} \;
find "${pkgdir}/usr/share/doc/python2/html/" -type d -exec chmod 0755 {} \;
mv "${pkgdir}/usr/share/doc/python2/html/Python.devhelp.gz" \
"${pkgdir}/usr/share/doc/python2/html/python2.devhelp.gz"
+ # Add Devhelp book
+ install -m 755 -d "${pkgdir}/usr/share/devhelp/books"
ln -s "../../doc/python2/html" "${pkgdir}/usr/share/devhelp/books/python2"
}