summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Shunick2016-07-14 01:41:26 -0400
committerAndrew Shunick2016-07-14 01:41:26 -0400
commitb57fb8236388998823dde5fd6f75fdd5e52d0fe9 (patch)
treee883675fc9dbef69c1960648ef181388ca48f63c /PKGBUILD
downloadaur-b57fb8236388998823dde5fd6f75fdd5e52d0fe9.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f4aaceda118
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andrew Shunick <andrew at shunick dot info>
+pkgname=python2-doom_py-git
+pkgver=r47.a242ce7
+pkgrel=1
+pkgdesc="Doom environment for OpenAI gym"
+arch=('any')
+url="https://gym.openai.com/"
+giturl="https://github.com/openai/doom-py"
+license=('MIT')
+provides=('python2-doom_py')
+depends=('python2' 'python2-numpy' 'python2-six' 'zlib' 'libjpeg' 'boost-libs' 'sdl2' 'wget' 'unzip')
+makedepends=('python2-setuptools' 'cmake' 'boost' 'gcc')
+source=("${pkgname}::git+${giturl}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $pkgname
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
+