summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJurica Bradarić2015-06-16 14:13:11 +0000
committerJurica Bradarić2015-06-16 14:13:11 +0000
commit97e224a7bfe6602ed1056fa3605e0cc62ea308bd (patch)
tree2627cf830bafcf5fc9e084808a507e4be0b4e0ee /PKGBUILD
downloadaur-97e224a7bfe6602ed1056fa3605e0cc62ea308bd.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f68749d00efc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jurica Bradaric <jbradaric@gmail.com>
+pkgname=python2-editrepl
+pkgver=2013.06.20
+pkgrel=1
+pkgdesc="Runs a terminal based editor inside your REPL session"
+arch=(any)
+url="https://github.com/philipbjorge/EditREPL"
+license=('custom: BSD')
+makedepends=('python2' 'python2-setuptools')
+
+source=("https://pypi.python.org/packages/source/E/EditREPL/EditREPL-$pkgver.tar.gz")
+sha256sums=('2cf966b27768389c82d4197a1df9c37c2b25ac6c4a019468168e93069637fdbb')
+
+build() {
+ cd "$srcdir/EditREPL-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/EditREPL-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}