summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-09-20 09:47:06 -0700
committerAndy Weidenbaum2015-09-20 09:47:06 -0700
commit61c8beab687e77268ccde4eab5001e0314d64c22 (patch)
tree0e86ae93dc6a45e31d4b75f44c362ecf06a3fdb5 /PKGBUILD
parent6ee306fb76fb2bade753c037d97b18e6db013d0a (diff)
downloadaur-61c8beab687e77268ccde4eab5001e0314d64c22.tar.gz
update pkgver to 2.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2aaa8c22214f..16284da5ca96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=python2-ethereum-serpent
-pkgver=2.0.0
+pkgver=2.0.1
pkgrel=1
pkgdesc="Serpent compiler, installed as a Python module"
arch=('i686' 'x86_64')
@@ -12,16 +12,16 @@ url="https://www.ethereum.org"
license=('WTFPL')
options=(!emptydirs)
source=(https://pypi.python.org/packages/source/e/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
-md5sums=('3d720bb2edf6a8f3a6ab026f6921df6b')
-sha256sums=('5473213f7f3e32330cf7d60a2722ebc4f6ac30bd8bc365a441b01c86ed563d48')
+md5sums=('a1507bab442bbd2a9e9f172c29af877a')
+sha256sums=('09da7bf4891ed6307edc43d2c1f49db02e94b30521ab99bc2ff1168d0f8f06c4')
prepare() {
cd "$srcdir/${pkgname#python2-}-$pkgver"
- msg 'Fixing Makefile...'
+ msg2 'Fixing Makefile...'
sed -i "s@/usr/local@/usr@g" Makefile
- msg 'Fixing Python version...'
+ msg2 'Fixing Python version...'
find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python#/usr/bin/python2#g'
find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/env python#/usr/bin/env python2#g'
}
@@ -29,16 +29,16 @@ prepare() {
build() {
cd "$srcdir/${pkgname#python2-}-$pkgver"
- msg 'Building...'
+ msg2 'Building...'
python2 setup.py build
}
package() {
cd "$srcdir/${pkgname#python2-}-$pkgver"
- msg 'Installing...'
+ msg2 'Installing...'
python2 setup.py install --root="$pkgdir" --optimize=1
- msg 'Removing conflicting serpent binary...'
+ msg2 'Removing conflicting serpent binary...'
rm -f "$pkgdir/usr/bin/serpent"
}