summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormorguldir2019-03-12 22:05:10 +0100
committermorguldir2019-03-12 22:05:10 +0100
commit1941612367d9a50fada266c5a9eccf8692910b55 (patch)
tree1ccf778000976f28ef1bfdf4d2f811f6cddba070 /PKGBUILD
downloadaur-1941612367d9a50fada266c5a9eccf8692910b55.tar.gz
Copy from old python2-evdev package and from python-evdev
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3d3cf7fa755
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: morguldir <morguldir@protonmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+pkgname=python2-evdev
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Python2 bindings for the Linux input subsystem"
+arch=(x86_64)
+url="https://python-evdev.readthedocs.io/en/latest/"
+license=(BSD)
+makedepends=(python2 git)
+_commit=34a7535e8e160c78bf923adc48a1f1f6bcdcaae8 # tags/v1.1.2
+source=("git+https://github.com/gvalkov/python-evdev#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd python-evdev
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+build() {
+ cd python-evdev
+ python2 setup.py build
+}
+
+package() {
+ cd python-evdev
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dt "$pkgdir/usr/share/licenses/python2-evdev" -m644 LICENSE
+}