summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-14 11:10:25 +0200
committerDaniel Peukert2020-06-14 11:10:25 +0200
commit98da90892d8eae0b79cb658431be18a5adc5fee3 (patch)
treed75fe2de238f37bf4e4c13e683cce9a224995787 /PKGBUILD
parent5969aad9ab03e2767337549b5980d9ab8506fae4 (diff)
downloadaur-98da90892d8eae0b79cb658431be18a5adc5fee3.tar.gz
Changed hashbang to python2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec41ebe916ba..fabb149bc054 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_projectname='fasteners'
pkgname="python2-$_projectname"
pkgver='0.15'
-pkgrel='3'
+pkgrel='4'
pkgdesc='A python package that provides useful locks - python2 version'
arch=('any')
url="https://github.com/harlowja/$_projectname"
@@ -17,6 +17,10 @@ sha256sums=('f77e2f9a2e3fb3d1570c8542ebbe437239a66f6edf141a8677c6002075abc01c')
_sourcedirectory="$_projectname-$pkgver"
+prepare() {
+ sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2.7|g' "$srcdir/$_sourcedirectory/setup.py"
+}
+
build() {
cd "$srcdir/$_sourcedirectory/"
python2 setup.py build