summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvlad2015-08-10 14:03:27 +0300
committervlad2015-08-10 14:03:27 +0300
commitf46e85a6d06fd88fffd8d4de8845661c8cf597de (patch)
tree8b19f68163913e6c9672e6147fb52051906c400b /PKGBUILD
parent2285e682e4d57690fb22fa09c45d80f6f86ced7e (diff)
downloadaur-python2-fusepy-git.tar.gz
cut off "v" prefix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afc32b92674c..bb081a1e7357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Nidhogg
pkgname='python2-fusepy-git'
-pkgver=v2.0.2.r1.g27d76e4
+pkgver=2.0.2.r1.g27d76e4
pkgrel=1
pkgdesc='Simple ctypes bindings for FUSE'
arch=('any')
license=('custom:ISCL')
-url='https://github.com/terencehonles/fusepy'
+url="https://github.com/terencehonles/fusepy"
depends=('fuse>=2.6' 'python2')
makedepends=('python2-setuptools')
conflicts=('python2-fuse')
-source=('git://github.com/terencehonles/fusepy.git')
+source=('git+https://github.com/terencehonles/fusepy.git')
md5sums=('SKIP')
pkgver() {
cd fusepy
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
package() {
@@ -24,5 +24,3 @@ package() {
sed -n '/Copyright/,/ THIS SOFTWARE[.]/p' fuse.py > LICENSE
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: