summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Yan2015-07-23 20:22:21 +0800
committerFelix Yan2015-07-23 20:22:21 +0800
commitb5950368bf584cf5b783a2921b9a7bbe6225d9d8 (patch)
tree4513f15549af37ad4356fa4a38ae5ae655cf665e /PKGBUILD
downloadaur-b5950368bf584cf5b783a2921b9a7bbe6225d9d8.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..107cc3cfbeab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+
+pkgname=python2-gcm
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="Python client for Google Cloud Messaging for Android (GCM)"
+arch=('any')
+url="https://github.com/geeknam/python-gcm"
+license=('custom')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("http://pypi.python.org/packages/source/p/python-gcm/python-gcm-$pkgver.tar.gz")
+
+build() {
+ cd python-gcm-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd python-gcm-$pkgver
+ python2 setup.py install --root="$pkgdir/"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+sha512sums=('bb7993d9674ddb6a5b2296105e0ea4ac4b1e980d7078922a8e9cf20c3e4ab60bc3d8b04ee417a9df93fc9e13a5d26908fe4e370b2841e214e114f0fa8fea0668')