summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxantares2015-06-09 00:05:23 +0200
committerxantares2015-06-09 00:05:23 +0200
commitaf457c0173c310c443783ee4ded5d5489602a31e (patch)
tree5e6a5be5837f049ca1a95d5d9472ea10eee5805a /PKGBUILD
downloadaur-af457c0173c310c443783ee4ded5d5489602a31e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bf5371e4859
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+
+pkgname=python2-george
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Fast Gaussian Processes for regression"
+url="http://dan.iel.fm/george"
+arch=(any)
+license=('MIT')
+depends=('python2-scipy')
+makedepends=('hodlr')
+source=("https://github.com/dfm/george/archive/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/george-$pkgver"
+ sed -i '62i"/usr/include",' setup.py
+ sed -i "s|assemble_Matrix(diag, tol_, 's', seed)|assemble_Matrix(diag, tol_, 's')|g" include/solver.h
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/george-$pkgver"
+ python2 setup.py install --root="${pkgdir}"
+}
+