summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTiago de Paula Peixoto2018-06-12 10:45:12 +0100
committerTiago de Paula Peixoto2018-06-12 10:45:12 +0100
commit2207212aabd9172e8f39353ed77b74f1d00db0d9 (patch)
tree420ec28b0ee5c508cfac50245bd911a513138598 /PKGBUILD
parentf3a634c92d3096937370bc0ebea43ea57ce58cf8 (diff)
downloadaur-2207212aabd9172e8f39353ed77b74f1d00db0d9.tar.gz
Fix build with GCC 8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 499cf1cac4be..2d33f5bcec35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,11 +14,14 @@ makedepends=(sparsehash)
optdepends=('graphviz: graph layout'
'python2-matplotlib: graph drawing')
options=(!libtool)
-source=("http://downloads.skewed.de/graph-tool/graph-tool-$pkgver.tar.bz2")
-sha256sums=('df6273dc5ef327a0eaf1ef1c46751fce4c0b7573880944e544287b85a068f770')
+source=("http://downloads.skewed.de/graph-tool/graph-tool-$pkgver.tar.bz2"
+ "https://git.skewed.de/count0/graph-tool/commit/9bd68ef9df7cadb2ca537037a425664ce14dc220.diff")
+sha256sums=('df6273dc5ef327a0eaf1ef1c46751fce4c0b7573880944e544287b85a068f770'
+ '89a56cd125b70ba074950ea6252bdd10a8b2e75cf6ee53b6b38e4855fe066373')
prepare() {
cd "$srcdir/graph-tool-$pkgver"
+ patch -p1 -i ../9bd68ef9df7cadb2ca537037a425664ce14dc220.diff
./configure --enable-openmp --prefix=/usr --docdir="/usr/share/doc/$pkgname" PYTHON=python2
}